adobe flash player因过期而遭到阻止的解决方法

2017-03-16 16:26 出处:其他 作者:佚名 责任编辑:lixianmei

  最近浏览器打开后老提示adobe flash player因过期而遭到阻止,让人很烦,这是什么原因?今天小编就为大家带来详细的解决方法,需要的朋友可以一起看看

adobe flash player因过期而遭到阻止截图界面:

◆起因

  大家先听我慢慢道来,这跟前不久我们跟踪报道的Hacking Team(以下简称HT)400GB内部资料泄露事件有莫大联系。如果说斯塔莫斯那句“Adobe是时候关闭Flash了”只能算预言的话,HT事件中的泄露数据便是直接导火索。如果Flash这次逃不过命运,一定永远不会忘记这400GB的数据吧。

  来看看昨天究竟发生了什么。

  HT泄露事件爆发后仅仅几天,Flash先后被曝出3个0day高危漏洞:CVE-2015-5119、CVE-2015-5122、CVE-2015-5123,各家浏览器终于坐不住了。13日也就是昨天,FireFox发布公告宣布全面禁用Flash。今天看来,不仅是FireFox,封锁屏蔽Flash Player插件的行动已经蔓延到其他各家,这事闹大了……

  事发后,有许多不明真相的用户尝试卸载、重装Flash Player,但依旧无法解决,反反复复考验着用户们的忍耐力。

  对此,Adobe再度紧急发布最新的18.0.0.209版本来修复……要知道,18.0.0.203版本才刚刚更新出来。几天时间频频更新打补丁,局外人看个热闹,但在从业人员眼中,你这个问题就大了。难道真被乔老爷子说中,Flash已经老了?面对频发的安全问题和经常无故“拖累”浏览器甚至导致崩溃的行为,难道真的就没人能救Flash了吗?

  如果Adobe拿不出解决方案,或许HTML5的时代就真的快要来了。

  今年2月,全球最大的视频网站YouTube便宣布将默认使用HTML5取代Flash做视频播放。对于越积越多的怨念,Adobe公司却表现得异常从容,表示不会放弃这款产品。Adobe高管Paul Burnett则认为“Flash的未来在网页游戏”。

  站在用户的角度小编想说,我们不在乎你的技术新旧,Flash老H5新这都无所谓,我们只想看到流畅+安全的体验,如果三番五次的解决不了,只有被时代抛弃的命运。

adobe flash player因过期而遭到阻止解决方法:

  在chrome浏览器网页输入框内输入 chrome://plugins.详细插件列表中找到adobe flash player的插件:

  选择始终允许,使用的是Mac系统,如果是windows系统,在chrome浏览器网页输入框内输入 chrome://plugins.详细插件列表中找到Flash项展开,禁用低版本的flash,重启浏览器即可。

  或者升级Flashplayer for 非IE内核的版本到最新,再升级Chrome版本到最新。两个都必须升!另外以前偶尔能正常升级Chrome,已经变成不弄VPN肯定升级不成功了。

◆解决办法

  不管Flash未来会怎样,眼下解决“Adobe Flash Player因过期而遭到阻止”的办法只有尽快更新18.0.0.209版本,或者多尝试其他备用浏览器碰碰运气,剩下别无他法。垄断,没有办法的事。

 

软件名称:
Adobe Flash Player最新版下载 v23.0.0.198 官方版(swf播放器)
软件大小:
21.8MB
更新时间:
2016-10-22

 

   需要注意的是,有网友反映安装了最新版本也没有解决问题,网页Flash还是不正常。这时候我建议大家查看一下浏览器插件列表,确认一下18.0.0.209的Flash Player是否替换掉旧版本。这个很关键,因为很多浏览器在适配插件上存在问题,所以大家安装完后一定要确认Flash新版本已经适配到位。

  我就拿Chrome举例,Chrome用户安装完新版本后几乎都会遇到,就是浏览器会默认新旧版本同时“启用”,而不是替换掉或者停用掉旧版本(不智能啊!),解决办法很简单,打开Chrome插件列表(浏览器直接输入chrome://plugins/即可),找到Adobe Flash Player项,“停用”掉旧版本,注意是把“启用”改为“停用”(不智能啊!),此时停用版本将被“灰”掉,如图:

  打开网页试一试,提示变了,点“始终运行”吧。其他浏览器我没有测试,现在最靠谱最保险的办法就是让浏览器成功适配到最新18.0.0.209版本的Adobe Flash Player,使用其他浏览器的用户也可按照以上思路来确认是否适配成功。

  实际上,解决这个问题还有个捷径,但绝对是【冒险的做法】,就是直接改exe程序目标,加上指令“ --allow-outdated-plugins”,注意--前需加空格,如图:

  我必须重申,这个办法很冒险!即便咱们不懂技术,allow outdated plugins是什么意思也能查到吧,“允许加载过期插件”,这个在安全圈里本身就是个大忌!我这里摆出来就是告诉大家切勿图方便使用此办法,中了网络上某些不怀好意之人的圈套。Flash本就脆弱,漏洞频发,可以想象加载过期插件的风险。

  先写这些,如果帮到大家欢迎把文章分享出去,再帮一帮其他还没解决问题正在着急的朋友。另外我在文章里只提到了Chrome的解决细节,所以欢迎使用其他浏览器的用户与大家分享解决之道,一起交流经验,小编先行谢过了。

最新资讯离线随时看 聊天吐槽赢奖品